summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2018-09-02 19:35:09 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2018-09-02 19:39:06 (EDT)
commit1b84ff941776877dbd15a06fe3da22422ad3a0a0 (patch)
tree3939d0ee9b515db2409e5e56c531fdec69b13c99 /configure.ac
parent3901e13de2b65d332f714638ebf8871cd3eceb9d (diff)
configure.ac, config.sh.in: Check for md5sum, sha256sum, and gzip
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac75
1 files changed, 75 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae4fbab..1e92c9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,81 @@ AC_ARG_WITH(
)
AC_ARG_WITH(
+ [md5sum],
+ [AS_HELP_STRING([--with-md5sum=PATH], [path to md5sum utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-md5sum requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([md5sum is required])
+ ;;
+ *)
+ MD5SUM="${withval}"
+ AC_SUBST([MD5SUM])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([MD5SUM], [md5sum])
+ if test -z "${MD5SUM}"; then
+ AC_MSG_ERROR([md5sum not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
+ [sha256sum],
+ [AS_HELP_STRING([--with-sha256sum=PATH], [path to sha256sum utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-sha256sum requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([sha256sum is required])
+ ;;
+ *)
+ SHA256SUM="${withval}"
+ AC_SUBST([SHA256SUM])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([SHA256SUM], [sha256sum])
+ if test -z "${SHA256SUM}"; then
+ AC_MSG_ERROR([sha256sum not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
+ [gzip],
+ [AS_HELP_STRING([--with-gzip=PATH], [path to gzip utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-gzip requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([gzip is required])
+ ;;
+ *)
+ GZIP="${withval}"
+ AC_SUBST([GZIP])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([GZIP], [gzip])
+ if test -z "${GZIP}"; then
+ AC_MSG_ERROR([gzip not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
[date],
[AS_HELP_STRING([--with-date=PATH],
[path to date utility with `%s' format specifier])],