summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2017-07-22 12:02:40 (EDT)
committer P. J. McDermott <pj@pehjota.net>2017-07-22 12:02:40 (EDT)
commit2bb8838e53bbf590220354bfa712a1d337b73946 (patch)
tree25ca622b5491b081ff637a95cff5548bacb69a02 /configure.ac
parent83982a5f83625f9704470c4d1c2babcf61a20b02 (diff)
configure.ac: New "IN_GIT" conditional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 219401c..41d3414 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,9 @@ AC_CONFIG_SRCDIR([src/pro-archman.sh])
AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
AM_SILENT_RULES([yes])
+AM_CONDITIONAL([IN_GIT],
+ [test -d "${srcdir}/.git" && command -v git >/dev/null 2>&1])
+
AC_ARG_WITH(
[sh],
[AS_HELP_STRING([--with-sh=PATH],