summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2017-07-22 18:06:12 (EDT)
committer P. J. McDermott <pj@pehjota.net>2017-07-22 18:06:12 (EDT)
commit9217f3869f76d6936e77cec0a1a4d5efd1e97727 (patch)
tree97255d75e43cebc41e7b779b109496e35b9c192e /configure.ac
parente0cc4b1883c98145d05a141e06a0392a3181e6e5 (diff)
parent98725484ac7bb96cd2ac6481c8460ceaa06dc4be (diff)
Merge branch 'feature/use-autoconf-automake-shpp-and-shld'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac59
1 files changed, 59 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..6d6b874
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,59 @@
+# Process this file with autoconf to produce a configure script.
+#
+# Copyright (C) 2013 Patrick "P. J." McDermott
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+AC_INIT([ProteanOS Archive Manager], [1.4.0],
+ [mailto:proteanos-dev@lists.proteanos.com], [pro-archman],
+ [http://www.proteanos.com/dev/pro-archman/])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_SRCDIR([src/main.sh])
+
+AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
+AM_SILENT_RULES([yes])
+
+AM_CONDITIONAL([IN_GIT],
+ [test -d "${srcdir}/.git" && command -v git >/dev/null 2>&1])
+
+AC_ARG_WITH(
+ [sh],
+ [AS_HELP_STRING([--with-sh=PATH],
+ [POSIX-conformant shell with `local'])],
+ dnl This `dnl' is needed to workaround Vim syntax highlighting.
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR([--with-sh requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([sh is required])
+ ;;
+ *)
+ SH="${withval}"
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([SH], [sh])
+ if test -z "${SH}"; then
+ AC_MSG_ERROR([sh not found])
+ fi
+ ]
+)
+
+AC_SUBST([SH])
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([config.sh])
+AC_OUTPUT()