summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2017-07-22 09:58:05 (EDT)
committer P. J. McDermott <pj@pehjota.net>2017-07-22 09:58:05 (EDT)
commitae8fb0f98c0c7776daa3594251618e0abee523e3 (patch)
treedc6f332af0fe235ec395de7d753481421f22a5cf /configure.ac
parente0cc4b1883c98145d05a141e06a0392a3181e6e5 (diff)
Switch to using GNU Autoconf and Automake
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac55
1 files changed, 55 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..6f56f26
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,55 @@
+# Process this file with autoconf to produce a configure script.
+#
+# Copyright (C) 2013 Patrick "P. J." McDermott
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+AC_INIT([ProteanOS Archive Manager], [1.4.0],
+ [mailto:proteanos-dev@lists.proteanos.com], [pro-archman],
+ [http://www.proteanos.com/dev/pro-archman/])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_SRCDIR([src/pro-archman.sh])
+
+AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
+AM_SILENT_RULES([yes])
+
+AC_ARG_WITH(
+ [sh],
+ [AS_HELP_STRING([--with-sh=PATH],
+ [POSIX-conformant shell with `local'])],
+ dnl This `dnl' is needed to workaround Vim syntax highlighting.
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR([--with-sh requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([sh is required])
+ ;;
+ *)
+ SH="${withval}"
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([SH], [sh])
+ if test -z "${SH}"; then
+ AC_MSG_ERROR([sh not found])
+ fi
+ ]
+)
+
+AC_SUBST([SH])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT()