summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2015-05-25 16:05:46 (EDT)
committer P. J. McDermott <pj@pehjota.net>2015-05-25 16:05:46 (EDT)
commitfe27982ac6e0bec91c9a9762b689018e50e47238 (patch)
treeef6e69dc411e56290e8fe32b075dcfee0bfc7f0a /Makefile.am
parent54eacca88673a1444f40cb049813d5cc8475f02c (diff)
parent50b6588d6350c7b15ffbcf5e0e704461861a8870 (diff)
Merge branch 'feature/block-device-mounting' into feature/installer-integration
Conflicts: locale/en_US.sh
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b55f926..4d1657b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,6 +56,8 @@ pkgdatacmddir = $(pkgdatadir)/cmd
pkgdataprofiledir = $(pkgdatadir)/profile
pkgdatapackagedir = $(pkgdatadir)/package
uninstall_dirs = \
+ '$(DESTDIR)$(pkglocalstatedir)/mount' \
+ '$(DESTDIR)$(pkglocalstatedir)' \
'$(DESTDIR)$(pkgdatapackagedir)' \
'$(DESTDIR)$(pkgdataprofiledir)' \
'$(DESTDIR)$(pkgdatacmddir)' \
@@ -92,6 +94,7 @@ do_subst = sed \
-e 's|[@]SH[@]|$(SH)|g' \
-e 's|[@]pkgdatadir[@]|$(pkgdatadir)|g' \
-e 's|[@]localedir[@]|$(localedir)|g' \
+ -e 's|[@]pkglocalstatedir[@]|$(pkglocalstatedir)|g' \
-e "s|[@]cmds[@]|$(cmds)|g" \
-e "s|[@]profiles[@]|$(profiles)|g" \
-e "s|[@]textdomain[@]|$(textdomain)|g"
@@ -150,6 +153,9 @@ wikiman: $(man1_MANS) $(man8_MANS)
>"$${f}.mdwn"; \
done
+install-exec-hook:
+ $(MKDIR_P) "$(DESTDIR)$(pkglocalstatedir)/mount"
+
install-data-local: $(locale_MESSAGES)
@$(NORMAL_INSTALL)
for f in $(locale_MESSAGES); do \