summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2014-08-26 15:07:41 (EDT)
committer P. J. McDermott <pj@pehjota.net>2014-08-26 15:07:41 (EDT)
commit45013122e99ebf578f00f8a0ca2e86c96b12908f (patch)
tree13a2cb00ac20d2cb93eab7da5efe0d857a330970 /Makefile.am
parent7e01eb17a4672d2b2ff421d7f8859cd167e259ce (diff)
Makefile.am: Add ssh mkdir command to "release"
Fixes: $ make release [...] md5sum prokit-0.1.0.tar.gz prokit-0.1.0.tar.bz2 prokit-0.1.0.tar.xz >MD5SUMS sha256sum prokit-0.1.0.tar.gz prokit-0.1.0.tar.bz2 prokit-0.1.0.tar.xz >SHA256SUMS rsync -az --progress --stats prokit-0.1.0.tar.gz prokit-0.1.0.tar.bz2 prokit-0.1.0.tar.xz MD5SUMS SHA256SUMS \ files@files.proteanos.com:files/pub/prokit/0.1.0/ sending incremental file list rsync: mkdir "/srv/files.proteanos.com/files/pub/prokit/0.1.0" failed: No such file or directory (2) rsync error: error in file IO (code 11) at main.c(595) [Receiver=3.0.7] rsync: connection unexpectedly closed (9 bytes received so far) [sender] rsync error: error in rsync protocol data stream (code 12) at io.c(605) [sender=3.0.9] make: *** [release] Error 12
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 80b76a2..24dea42 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -174,6 +174,7 @@ release:
git push --tags origin master:master
md5sum $(DIST_ARCHIVES) >MD5SUMS
sha256sum $(DIST_ARCHIVES) >SHA256SUMS
+ ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE)
rsync -az --progress --stats $(DIST_ARCHIVES) MD5SUMS SHA256SUMS \
files@files.proteanos.com:files/pub/$(PACKAGE)/$(VERSION)/
'$(srcdir)/scripts/announce-release.sh' \