summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2014-08-15 12:22:52 (EDT)
committer P. J. McDermott <pj@pehjota.net>2014-08-15 12:22:52 (EDT)
commit4fca121dedab688a2814651de29199693a196bd7 (patch)
treed58da61be50c7f84a72ffd6bb35e069287bb5a93 /Makefile.am
parentffbed80bb10a49f94932963ced88e18e7d49fa7b (diff)
Makefile.am: New "profiles" variable
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d00cdf..fefa87a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,6 +46,8 @@ SUFFIXES = .sh .sm
cmds = $$(printf '%s ' $(pkgdatacmd_SCRIPTS) | \
sed -e 's|[^ ]*/\([^ ]*\)\.sm |\1 |g')
+profiles = $$(printf '%s ' $(pkgdataprofile_SCRIPTS) | \
+ sed -e 's|[^ ]*/\([^ ]*\)\.sm |\1 |g')
textdomain = $$(printf '%s\n' '$(PACKAGE)' | sed -e 's|-|_|g')
do_subst = sed \
-e 's|[@]PACKAGE_NAME[@]|$(PACKAGE_NAME)|g' \
@@ -55,6 +57,7 @@ do_subst = sed \
-e 's|[@]pkgdatacmddir[@]|$(pkgdatacmddir)|g' \
-e 's|[@]localedir[@]|$(localedir)|g' \
-e "s|[@]cmds[@]|$(cmds)|g" \
+ -e "s|[@]profiles[@]|$(profiles)|g" \
-e "s|[@]textdomain[@]|$(textdomain)|g"
in-place: