summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-10-23 16:32:09 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-10-23 16:32:09 (EDT)
commit53d8e5d15564a8955b3b5a2e954eb6b13fc4d6af (patch)
tree9958a16c0c0a491dd5b33292b9058f5838f310d9 /Makefile.am
parentfc3a2c153ba7205556380d44298768afae4729ea (diff)
Makefile.am: New "uninstall-local" target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 10ae841..bcf60b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -67,6 +67,14 @@ install-data-local: $(locale_MESSAGES)
exit $$?; \
done
+uninstall-local:
+ @$(NORMAL_UNINSTALL)
+ for f in $(locale_MESSAGES); do \
+ ff="$${f#*/}"; \
+ dir="$(DESTDIR)$(localedir)/$${f%.ms}/LC_MESSAGES"; \
+ rm -f "$${dir}/$(textdomain).ms"; \
+ done
+
really-clean: distclean
rm -Rf $(srcdir)/aclocal.m4 $(srcdir)/autom4te.cache/ \
$(srcdir)/configure \