summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-10-23 17:12:57 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-10-23 17:38:24 (EDT)
commit594c77a22e22da38a216a4b141ba8078b3431b53 (patch)
treeeb248f16d7fde2fcf1bb3956bcdae166b93a5a28 /Makefile.am
parent1f97ffd3d1cbe36c08ac0b63427d69855429c3ec (diff)
Makefile.am: New "uninstall-hook" rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e936653..9c3ae4b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,6 +75,13 @@ uninstall-local:
rm -f "$${dir}/$(textdomain).ms"; \
done
+uninstall-hook:
+ for dir in '$(DESTDIR)$(pkgdatacmddir)' '$(DESTDIR)$(pkgdatadir)'; do \
+ if [ -d "$${dir}" ]; then \
+ rmdir "$${dir}"; \
+ fi; \
+ done
+
really-clean: distclean
rm -Rf $(srcdir)/aclocal.m4 $(srcdir)/autom4te.cache/ \
$(srcdir)/configure \