summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2014-08-19 10:26:31 (EDT)
committer P. J. McDermott <pj@pehjota.net>2014-08-19 10:26:31 (EDT)
commit5f2f59c8ddd07e465449f1f579b28f9617e8fb8c (patch)
tree79fe5864be1772d37e0f13d38644ae1b9f3631d6 /Makefile.am
parent1b41c444b854fdbd44885bfdb39d5e4815a1abe6 (diff)
Makefile.am: Remove pkgdataprofiledir on uninstall
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f15069..cf26f83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,10 @@ CLEANFILES = \
.builddirstamp
pkgdatacmddir = $(pkgdatadir)/cmd
pkgdataprofiledir = $(pkgdatadir)/profiles
+uninstall_dirs = \
+ '$(DESTDIR)$(pkgdataprofiledir)' \
+ '$(DESTDIR)$(pkgdatacmddir)' \
+ '$(DESTDIR)$(pkgdatadir)'
EXTRA_DIST = \
autogen.sh \
$(bin_sources) \
@@ -89,7 +93,7 @@ uninstall-local:
done
uninstall-hook:
- for dir in '$(DESTDIR)$(pkgdatacmddir)' '$(DESTDIR)$(pkgdatadir)'; do \
+ for dir in $(uninstall_dirs); do \
if [ -d "$${dir}" ]; then \
rmdir "$${dir}"; \
fi; \