summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-10-23 11:59:35 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-10-23 12:00:33 (EDT)
commitb0d036cb281a9d59946409810b98a175877006fb (patch)
tree9d00ecede3970b98a39c2fc6cef2e3d70a08c567 /Makefile.am
parent3e3cbd6e0a225767b92ac8aad590539caec3525e (diff)
Makefile.am: Add .sh.sm inference rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f80629..129ff23 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,7 @@ EXTRA_DIST = \
$(pkgdata_sources) \
$(pkgdatacmd_sources)
-SUFFIXES = .sh
+SUFFIXES = .sh .sm
do_subst = sed \
-e 's|[@]PACKAGE[@]|$(PACKAGE)|g' \
@@ -62,3 +62,7 @@ dist-hook:
$(MKDIR_P) "$$(dirname $@)"
$(do_subst) $< >$@
chmod a+x $@
+
+.sh.sm:
+ $(MKDIR_P) "$$(dirname $@)"
+ $(do_subst) $< >$@