summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2014-08-21 21:19:27 (EDT)
committer P. J. McDermott <pj@pehjota.net>2014-08-21 21:19:27 (EDT)
commitc20d3437cb1f1ff5df5daf98e3f657fe3f59021e (patch)
tree6a2ade959485873c490c8da1cf1c3b1d0088dab0 /Makefile.am
parentb6dbbdfeb5375af587ebd0d41e9269cbe9418a12 (diff)
Makefile.am: New "todo" target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 38 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cf26f83..4a03a4f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,8 +41,7 @@ uninstall_dirs = \
'$(DESTDIR)$(pkgdataprofiledir)' \
'$(DESTDIR)$(pkgdatacmddir)' \
'$(DESTDIR)$(pkgdatadir)'
-EXTRA_DIST = \
- autogen.sh \
+sources = \
$(bin_sources) \
$(pkgdata_sources) \
$(pkgdatacmd_sources) \
@@ -51,6 +50,9 @@ EXTRA_DIST = \
$(TESTS) \
tests/common.sh \
tests/parse_control.common.sh
+EXTRA_DIST = \
+ autogen.sh \
+ $(sources)
SUFFIXES = .sh .sm
@@ -74,6 +76,40 @@ AM_TESTS_ENVIRONMENT = srcdir=$(top_srcdir) COLOR_TEST_LOGS=$(COLOR_TEST_LOGS)
.builddirstamp:
touch .builddirstamp
+todo_script = \
+ /^[0-9]* .[ \t]*\#[ \t]*TODO/,/^[0-9]* .[ \t]*[^\#]/{ \
+ /^[0-9]* .[ \t]*\#/p; \
+ }; \
+ /^[0-9]* .[ \t]*\#[ \t]*FIXME/,/^[0-9]* .[ \t]*[^\#]/{ \
+ /^[0-9]* .[ \t]*\#/p; \
+ }; \
+ /^[0-9]* .[ \t]*\#[ \t]*XXX/,/^[0-9]* .[ \t]*[^\#]/{ \
+ /^[0-9]* .[ \t]*\#/p; \
+ };
+todo:
+ @set -e; \
+ printf '\n'; \
+ printf 'Code comments:\n'; \
+ printf '==============\n\n'; \
+ for f in $(sources); do \
+ printed=false; \
+ sed '=' "$(top_srcdir)/$${f}" | sed 'N; s/\n/ ./' | sed -n \
+ '$(todo_script)' | while read -r lineno line; do \
+ if ! $${printed}; then \
+ printf '%s:\n' "$${f}"; \
+ printed=true; \
+ fi; \
+ printf ' %6d %s\n' $${lineno} "$${line#.}"; \
+ done; \
+ done; \
+ printf '\n'; \
+ if [ -f '$(top_srcdir)/TODO' ]; then \
+ printf 'TODO file:\n'; \
+ printf '==========\n\n'; \
+ cat '$(top_srcdir)/TODO'; \
+ printf '\n'; \
+ fi
+
install-data-local: $(locale_MESSAGES)
@$(NORMAL_INSTALL)
for f in $(locale_MESSAGES); do \