summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2014-09-01 17:42:47 (EDT)
committer P. J. McDermott <pj@pehjota.net>2014-09-01 17:42:47 (EDT)
commitd6bd6dd94faa21ee19da52c1cbb756b43bb523f2 (patch)
tree5d8d8745c6a73206d62a3ff6c45dc27027463eb6 /Makefile.am
parentee7094433c2eb9f75d85704f87cba8bc545dc070 (diff)
Move some manuals to section 8
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3cfa4ce..889b3c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,7 @@ pkgdatacmd_SCRIPTS = $(pkgdatacmd_sources:.sh=.sm)
pkgdataprofile_SCRIPTS = $(pkgdataprofile_sources:.sh=.sm)
pkgdatapackage_SCRIPTS = $(pkgdatapackage_sources:.sh=.sm)
man1_MANS = $(man1_sources:.1in=.1)
+man8_MANS = $(man8_sources:.8in=.8)
locale_MESSAGES = $(locale_sources:.sh=.ms)
noinst_DATA = $(locale_MESSAGES) .builddirstamp
CLEANFILES = \
@@ -44,6 +45,7 @@ CLEANFILES = \
$(pkgdataprofile_SCRIPTS) \
$(pkgdatapackage_SCRIPTS) \
$(man1_MANS) \
+ $(man8_MANS) \
$(locale_MESSAGES) \
.builddirstamp
pkgdatacmddir = $(pkgdatadir)/cmd
@@ -61,6 +63,7 @@ sources = \
$(pkgdataprofile_sources) \
$(pkgdatapackage_sources) \
$(man1_sources) \
+ $(man8_sources) \
$(locale_sources) \
$(TESTS) \
tests/common.sh \
@@ -70,7 +73,7 @@ EXTRA_DIST = \
$(sources) \
scripts/announce-release.sh
-SUFFIXES = .sh .sm .1in .1 .ms
+SUFFIXES = .sh .sm .1in .1 .8in .8 .ms
cmds = $$(printf '%s ' $(pkgdatacmd_SCRIPTS) | \
sed -e 's|[^ ]*/\([^ ]*\)\.sm |\1 |g')
@@ -199,6 +202,10 @@ release:
$(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"
$(AM_V_at)$(do_subst) $< >$@
+.8in.8:
+ $(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"
+ $(AM_V_at)$(do_subst) $< >$@
+
.sh.ms:
$(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"
$(AM_V_at)cp $< $@