summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-10-22 12:46:58 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-10-22 12:46:58 (EDT)
commitdcfc46ea2334636c9c4dee677e975e1cb96920de (patch)
tree5c68f1334f3c6168f782efedeec6b0f898524f34 /Makefile.am
Set up build system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..c3d076b
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,46 @@
+# Process this file with automake to produce an input makefile.
+#
+# Copyright (C) 2013 Patrick "P. J." McDermott
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+include $(top_srcdir)/src/local.mk
+
+bin_SCRIPTS = $(bin_sources:.sh=)
+CLEANFILES = $(bin_SCRIPTS)
+EXTRA_DIST = \
+ autogen.sh \
+ $(bin_sources)
+
+SUFFIXES = .sh
+
+do_subst = sed \
+ -e 's|[@]PACKAGE[@]|$(PACKAGE)|g' \
+ -e 's|[@]VERSION[@]|$(VERSION)|g' \
+ -e 's|[@]SH[@]|$(SH)|g' \
+ -e 's|[@]libdir[@]|$(libdir)|g'
+
+in-place:
+ $(MAKE) $(AM_MAKEFLAGS) libdir=lib all-am
+
+reallyclean: distclean
+ rm -Rf $(srcdir)/aclocal.m4 $(srcdir)/autom4te.cache/ \
+ $(srcdir)/configure \
+ $(srcdir)/build-aux/ $(srcdir)/INSTALL $(srcdir)/Makefile.in \
+ $(srcdir)/ChangeLog
+
+.sh:
+ $(MKDIR_P) "$$(dirname $@)"
+ $(do_subst) $< >$@
+ chmod a+x $@