summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2015-05-25 16:05:46 (EDT)
committer P. J. McDermott <pj@pehjota.net>2015-05-25 16:05:46 (EDT)
commitfe27982ac6e0bec91c9a9762b689018e50e47238 (patch)
treeef6e69dc411e56290e8fe32b075dcfee0bfc7f0a /configure.ac
parent54eacca88673a1444f40cb049813d5cc8475f02c (diff)
parent50b6588d6350c7b15ffbcf5e0e704461861a8870 (diff)
Merge branch 'feature/block-device-mounting' into feature/installer-integration
Conflicts: locale/en_US.sh
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9e2c78..01d7dc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,23 @@ AC_CONFIG_SRCDIR([src/prokit.sh])
AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
AM_SILENT_RULES([yes])
+if test "x${localstatedir}" = 'x${prefix}/var'; then
+ case "${prefix}" in
+ NONE | */local | */local/*)
+ pkglocalstatedir='/var/local/prokit'
+ ;;
+ /opt | /opt/*)
+ pkglocalstatedir='/var/opt/prokit'
+ ;;
+ *)
+ pkglocalstatedir='/var/lib/prokit'
+ ;;
+ esac
+else
+ pkglocalstatedir='${localstatedir}/lib/prokit'
+fi
+AC_SUBST([pkglocalstatedir])
+
AC_ARG_WITH(
[sh],
[AS_HELP_STRING([--with-sh], [POSIX-conformant shell with `local'])],