summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c3d076b..286a770 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,14 @@ reallyclean: distclean
$(srcdir)/build-aux/ $(srcdir)/INSTALL $(srcdir)/Makefile.in \
$(srcdir)/ChangeLog
+dist-hook:
+ if [ -d '$(srcdir)/.git' ]; then \
+ printf 'Generated file. Do not edit.\n\n' \
+ >'$(distdir)/ChangeLog~'; \
+ git log --stat >>'$(distdir)/ChangeLog~'; \
+ mv '$(distdir)/ChangeLog~' '$(distdir)/ChangeLog'; \
+ fi
+
.sh:
$(MKDIR_P) "$$(dirname $@)"
$(do_subst) $< >$@