summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f80629..129ff23 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,7 @@ EXTRA_DIST = \
$(pkgdata_sources) \
$(pkgdatacmd_sources)
-SUFFIXES = .sh
+SUFFIXES = .sh .sm
do_subst = sed \
-e 's|[@]PACKAGE[@]|$(PACKAGE)|g' \
@@ -62,3 +62,7 @@ dist-hook:
$(MKDIR_P) "$$(dirname $@)"
$(do_subst) $< >$@
chmod a+x $@
+
+.sh.sm:
+ $(MKDIR_P) "$$(dirname $@)"
+ $(do_subst) $< >$@