summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 29 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8414b8c..9579fc3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
# Process this file with automake to produce an input makefile.
#
-# Copyright (C) 2017 Patrick McDermott
+# Copyright (C) 2017, 2018 Patrick McDermott
#
# This file is part of wolfssl-util.
#
@@ -17,6 +17,8 @@
# You should have received a copy of the GNU General Public License
# along with wolfssl-util. If not, see <http://www.gnu.org/licenses/>.
+KEY = '2250 31F0 47FF E516 63ED 516F 1A45 9ECD E4D6 04BE'
+
if IN_GIT
PACKAGE_VERSION_GIT = $$(printf ' (%s)' \
"$$({ git describe --tags --dirty 2>/dev/null || \
@@ -63,5 +65,31 @@ version.c: $(wolfssl_util_OBJECTS) $(wolfssl_util_DEPENDENCIES)
$(AM_V_GEN)printf 'const char *PACKAGE_VERSION_GIT = "%s";\n' \
"$(PACKAGE_VERSION_GIT)" >version.c
+release:
+ sed "s/^Released: ????-??-??\$$/Released: $$(date '+%Y-%m-%d')/" \
+ '$(srcdir)/NEWS' >'$(srcdir)/NEWS~'
+ mv '$(srcdir)/NEWS~' '$(srcdir)/NEWS'
+ $(MAKE) distcheck
+ set -e; \
+ export GIT_DIR='$(srcdir)/.git'; \
+ export GIT_WORK_TREE='$(srcdir)'; \
+ git commit -m 'NEWS: Release $(PACKAGE) $(VERSION)' -- NEWS; \
+ git tag '$(PACKAGE)/$(VERSION)' HEAD; \
+ git push --tags origin master:master
+ md5sum $(DIST_ARCHIVES) >MD5SUMS
+ sha256sum $(DIST_ARCHIVES) >SHA256SUMS
+ set -e; \
+ sigs=''; \
+ for f in $(DIST_ARCHIVES); do \
+ gpg --local-user $(KEY) --armor --detach-sign $${f}; \
+ sigs="$${sigs} $${f}.asc"; \
+ done; \
+ ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE); \
+ rsync -az --progress --stats $(DIST_ARCHIVES) $${sigs} \
+ MD5SUMS SHA256SUMS \
+ files@files.proteanos.com:files/pub/$(PACKAGE)/$(VERSION)/
+ '$(srcdir)/scripts/announce-release.sh' \
+ $(PACKAGE) $(VERSION) '$(PACKAGE_NAME)'
+
include $(top_srcdir)/src/local.mk
include $(top_srcdir)/tests/local.mk