summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2018-12-22 21:42:43 (EST)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2018-12-22 21:42:43 (EST)
commit3c6cac5e14046c3665f5d294b8846aac7c546062 (patch)
tree6a62b5b9b808b811ce217bd9896d73e29a16921c /Makefile.am
parent41d5e7b3fc646e6565aead0be557da6add6dd73d (diff)
configure.ac, Makefile.am: Set PACKAGE_VERSION_GIT
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 76d8f2c..d2e114f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,12 @@ include $(top_srcdir)/man/local.mk
include $(top_srcdir)/locale/local.mk
include $(top_srcdir)/tests/local.mk
+if IN_GIT
+PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^.*/||')
+else
+PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
+endif
+
MANUAL = Distribution Build System
SHSOEXT = .shso