summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 76d8f2c..d2e114f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,12 @@ include $(top_srcdir)/man/local.mk
include $(top_srcdir)/locale/local.mk
include $(top_srcdir)/tests/local.mk
+if IN_GIT
+PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^.*/||')
+else
+PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
+endif
+
MANUAL = Distribution Build System
SHSOEXT = .shso