summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2023-04-12 02:10:21 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2023-04-12 02:10:21 (EDT)
commit1ac60f77f9f52f180ce8e004034625440aa2bd19 (patch)
treee51bee7de8ec955343beb165c5f5d94539a6fbe3 /Makefile.am
parent2710882a528c5e68cf8a647d5b6d3f100d52a9ff (diff)
build: Link against zlib
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d60b35..9f5c00a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,9 +46,11 @@ opkg_opk_SOURCES =
opkg_opk_CFLAGS = \
$(WARN_CFLAGS) \
$(ASAN_CFLAGS)
-opkg_opk_CPPFLAGS =
+opkg_opk_CPPFLAGS = \
+ $(ZLIB_CFLAGS)
opkg_opk_LDADD = \
- $(ASAN_CFLAGS)
+ $(ASAN_CFLAGS) \
+ $(ZLIB_LIBS)
opkg_opk_LINK = $(LINK) version.c
EXTRA_opkg_opk_DEPENDENCIES = version.c
CLEANFILES = version.c