summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0beab1e..62f3e2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,30 @@ AC_ARG_ENABLE(
)
AC_ARG_WITH(
+ [library-path],
+ [AS_HELP_STRING([--with-library-path=PATH],
+ [colon-separated list of library directories])],
+ [
+ opt='library-path'
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-${opt} requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([${opt} is required])
+ ;;
+ *)
+ library_path="${withval}"
+ ;;
+ esac
+ ],
+ [
+ library_path='$(libdir)'
+ ]
+)
+
+AC_ARG_WITH(
[opkbuild-helpers],
[AS_HELP_STRING([--with-opkbuild-helpers=PATH],
[specify directory to install opkbuild helper script])],
@@ -146,6 +170,7 @@ AC_SUBST([SH])
AC_SUBST([READELF])
AC_SUBST([OPKG])
AC_SUBST([multiarch_libdir])
+AC_SUBST([library_path])
AC_SUBST([helperdir])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT()