summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2019-03-22 12:41:09 (EDT)
committer P. J. McDermott <pj@pehjota.net>2019-03-22 12:41:09 (EDT)
commitfa0ed86cbefd4a45d190f2ce1b2594e46addef2d (patch)
treedde534bd0bf7cc45ec8f141726c320b61fe94966 /configure.ac
parent267c3778366d1eb1b533c0472894a6ccf4dc5409 (diff)
configure.ac, Makefile.am: Substitute @library_path@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0beab1e..62f3e2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,30 @@ AC_ARG_ENABLE(
)
AC_ARG_WITH(
+ [library-path],
+ [AS_HELP_STRING([--with-library-path=PATH],
+ [colon-separated list of library directories])],
+ [
+ opt='library-path'
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-${opt} requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([${opt} is required])
+ ;;
+ *)
+ library_path="${withval}"
+ ;;
+ esac
+ ],
+ [
+ library_path='$(libdir)'
+ ]
+)
+
+AC_ARG_WITH(
[opkbuild-helpers],
[AS_HELP_STRING([--with-opkbuild-helpers=PATH],
[specify directory to install opkbuild helper script])],
@@ -146,6 +170,7 @@ AC_SUBST([SH])
AC_SUBST([READELF])
AC_SUBST([OPKG])
AC_SUBST([multiarch_libdir])
+AC_SUBST([library_path])
AC_SUBST([helperdir])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT()