summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2020-06-29 01:49:42 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2020-06-29 01:49:42 (EDT)
commit7d1bbaed9410a27390909a52d628d51254954a71 (patch)
tree2be19d95fb29a6606995d71a3b914fdf9177708e
parenteb7b301625bd8319b45ec47dce2462c06ac4050d (diff)
Add patch to fix empty index tests
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/0002-tests-add-feed.sh-Fix-empty-index-tests.patch60
-rw-r--r--debian/patches/series1
3 files changed, 62 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a327358..5fc320d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
pro-archman (2.1.0-2) UNRELEASED; urgency=medium
- * Backport a patch from upstream to fix a failure to sign empty feed
+ * Backport patches from upstream to fix a failure to sign empty feed
index files.
-- Patrick McDermott <patrick.mcdermott@libiquity.com> Mon, 29 Jun 2020 01:33:21 -0400
diff --git a/debian/patches/0002-tests-add-feed.sh-Fix-empty-index-tests.patch b/debian/patches/0002-tests-add-feed.sh-Fix-empty-index-tests.patch
new file mode 100644
index 0000000..4a3d33a
--- /dev/null
+++ b/debian/patches/0002-tests-add-feed.sh-Fix-empty-index-tests.patch
@@ -0,0 +1,60 @@
+From c265093e1bfe6afb0c381cdee417f7ae3ce5287e Mon Sep 17 00:00:00 2001
+From: Patrick McDermott <patrick.mcdermott@libiquity.com>
+Date: Mon, 29 Jun 2020 01:46:40 -0400
+Subject: [PATCH] tests/add-feed.sh: Fix empty index tests
+
+---
+ tests/add-feed.sh | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/tests/add-feed.sh b/tests/add-feed.sh
+index 843ede1..53472f8 100755
+--- a/tests/add-feed.sh
++++ b/tests/add-feed.sh
+@@ -33,7 +33,7 @@ command_ok_ 'feed index exists' -- \
+
+ command_ok_ 'feed index is empty' -- \
+ [ $(wc -l 'archive/feeds/dev/trunk/arch1/plat1/sect1/Packages' | \
+- cut -d ' ' -f 1) -eq 0 ]
++ cut -d ' ' -f 1) -eq 1 ]
+
+ changes="$(make_opks_and_changes 'foo' 'foo bar' '1.0-1' 'arch1' 'plat1' \
+ 'trunk' 'sect1')"
+@@ -43,7 +43,7 @@ command_ok_ 'pro-archman include' -- \
+
+ command_ok_ 'feed index is non-empty' -- \
+ [ $(wc -l 'archive/feeds/dev/trunk/arch1/plat1/sect1/Packages' | \
+- cut -d ' ' -f 1) -ne 0 ]
++ cut -d ' ' -f 1) -gt 1 ]
+
+ command_ok_ 'pro-archman add-feed' -- \
+ "${PRO_ARCHMAN}" -v -b 'archive/' add-feed \
+@@ -54,7 +54,7 @@ command_ok_ 'feed index exists' -- \
+
+ command_ok_ 'feed index is empty' -- \
+ [ $(wc -l 'archive/feeds/dev/trunk/arch1/plat1/sect2/Packages' | \
+- cut -d ' ' -f 1) -eq 0 ]
++ cut -d ' ' -f 1) -eq 1 ]
+
+ command_ok_ 'pro-archman add-feed' -- \
+ "${PRO_ARCHMAN}" -v -b 'archive/' add-feed \
+@@ -66,14 +66,14 @@ command_ok_ 'feed index exists' -- \
+
+ command_ok_ 'feed index is empty' -- \
+ [ $(wc -l 'archive/feeds/dev/trunk/arch2/plat2/sect1/Packages' | \
+- cut -d ' ' -f 1) -eq 0 ]
++ cut -d ' ' -f 1) -eq 1 ]
+
+ command_ok_ 'feed index exists' -- \
+ [ -f 'archive/feeds/dev/trunk/arch2/plat2/sect2/Packages' ]
+
+ command_ok_ 'feed index is empty' -- \
+ [ $(wc -l 'archive/feeds/dev/trunk/arch2/plat2/sect2/Packages' | \
+- cut -d ' ' -f 1) -eq 0 ]
++ cut -d ' ' -f 1) -eq 1 ]
+
+ command_ok_ 'pro-archman add-feed' -- not \
+ "${PRO_ARCHMAN}" -v -b 'archive/' add-feed \
+--
+2.11.0
+
diff --git a/debian/patches/series b/debian/patches/series
index f9ee640..4f18455 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-update_feeds-Fix-usign-errors-on-empty-indices.patch
+0002-tests-add-feed.sh-Fix-empty-index-tests.patch