summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2013-10-13 14:53:32 (EDT)
committer P. J. McDermott <pj@pehjota.net>2013-10-13 14:53:32 (EDT)
commit98ac510522c8f44aff1f9f1eaf027f2817ffe7c1 (patch)
tree633d932b8123d061ac82e72d25116223a57fa905
parent3110ba10faa152787d581830de0ffd56929ab764 (diff)
debian/rules: Add {get,unpack}-orig-source.
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 9b040d7..c61818f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,3 +8,21 @@
override_dh_auto_configure:
dh_auto_configure -- --libdir=/usr/share
+
+get-orig-source:
+ uscan --noconf --verbose --rename --force-download \
+ --download-current-version
+
+unpack-orig-source:
+ for f in *; do \
+ if [ -e $${f} ] && [ $${f} != debian ]; then \
+ rm -Rf $${f}; \
+ fi; \
+ done
+ set -e; \
+ source=$$(dpkg-parsechangelog | sed -n 's/^Source: //p'); \
+ version=$$(dpkg-parsechangelog | \
+ sed -n 's/^Version: \([^-]*\).*$$/\1/p'); \
+ tar -xJf ../$${source}_$${version}.orig.tar.xz; \
+ mv $${source}-$${version}/* .; \
+ rmdir $${source}-$${version}/