summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2017-07-22 20:33:28 (EDT)
committer P. J. McDermott <pj@pehjota.net>2017-07-22 20:33:28 (EDT)
commitb8a49b3e55f5cab15da7e3d2a91481e1e1c69db5 (patch)
tree2a74a2927a1c85d37a926c56525042dbacfb4890 /Makefile.am
parente23c6753dbf96b08470e00c02169fdcbe7433c97 (diff)
Makefile.am: Generate .builddirstamp
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 30dac88..b6ea4ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,10 +56,13 @@ do_subst = sed \
-e "s|[@]PACKAGE_VERSION[@]|$(PACKAGE_VERSION_GIT)|g" \
-e 's|[@]MANUAL[@]|$(MANUAL)|g'
+noinst_DATA += .builddirstamp
+
CLEANFILES = \
$(pro_archman_LDADD) \
$(locale_MESSAGES) \
- $(man1_MANS)
+ $(man1_MANS) \
+ .builddirstamp
EXTRA_DIST = \
autogen.sh \
$(locale_sources) \
@@ -68,6 +71,9 @@ EXTRA_DIST = \
tools/shpp.sh \
tools/shld.sh
+.builddirstamp:
+ $(AM_V_GEN)touch .builddirstamp
+
install-data-local: $(locale_MESSAGES)
@$(NORMAL_INSTALL)
for f in $(locale_MESSAGES); do \