summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2017-07-22 14:22:46 (EDT)
committer P. J. McDermott <pj@pehjota.net>2017-07-22 14:22:46 (EDT)
commitc87d460b0ba6e40faf4adaef7aabe16e0913846f (patch)
tree05dc27471c598ae687eb4d4ff33e125881690f7b /Makefile.am
parent7454a3f122a0055f50e68cae7520962b454e3133 (diff)
Makefile.am: Set and use TEXTDOMAIN instead of textdomain
Also set MANUAL.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 039c31e..24c90da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,6 +21,9 @@ else
PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
endif
+MANUAL = ProteanOS Archive Manager Manual
+TEXTDOMAIN = $$(printf '%s\n' '$(PACKAGE)' | sed -e 's|-|_|g')
+
SUFFIXES = .sh .sho .ms .1in .1
# This PACKAGE_VERSION stuff is a rather gross hack, but it's the only reliable
@@ -62,7 +65,6 @@ EXTRA_DIST = \
tools/shpp.sh \
tools/shld.sh
-textdomain = $$(printf '%s\n' '$(PACKAGE)' | sed -e 's|-|_|g')
do_subst = sed \
-e 's|@[@]PACKAGE_NAME[@]@|$(PACKAGE)|g' \
-e 's|@[@]PACKAGE_VERSION[@]@|$(PACKAGE_VERSION)|g' \
@@ -89,7 +91,7 @@ install-data-local: $(locale_MESSAGES)
ff="$${f#*/}"; \
dir="$(DESTDIR)$(localedir)/$${ff%.ms}/LC_MESSAGES"; \
$(MKDIR_P) "$${dir}" || exit 1; \
- $(INSTALL_DATA) "$${f}" "$${dir}/$(textdomain).ms" || \
+ $(INSTALL_DATA) "$${f}" "$${dir}/$(TEXTDOMAIN).ms" || \
exit $${?}; \
done
@@ -98,7 +100,7 @@ uninstall-local:
for f in $(locale_MESSAGES); do \
ff="$${f#*/}"; \
dir="$(DESTDIR)$(localedir)/$${ff%.ms}/LC_MESSAGES"; \
- rm -f "$${dir}/$(textdomain).ms"; \
+ rm -f "$${dir}/$(TEXTDOMAIN).ms"; \
done
uninstall-hook: