summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-04-16 11:25:34 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-04-16 11:25:34 (EDT)
commit536e10d9799c787b4c2a944510f66a04b48072ce (patch)
tree74a1b02c6bbf48be560f00cbb41bc4a8428330cf /Makefile.am
parentc4ca9a02f89fcc332deebd90e1354157485a67e4 (diff)
Makefile.am: Set signing key
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bda3faa..ed99230 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,8 @@
# along with the ProteanOS Development Kit. If not, see
# <http://www.gnu.org/licenses/>.
+KEY = '2250 31F0 47FF E516 63ED 516F 1A45 9ECD E4D6 04BE'
+
if IN_GIT
PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^.*/||')
else
@@ -193,7 +195,7 @@ release:
set -e; \
sigs=''; \
for f in $(DIST_ARCHIVES); do \
- gpg --armor --sign $${f}; \
+ gpg --local-user $(KEY) --armor --sign $${f}; \
sigs="$${sigs} $${f}.asc"; \
done; \
ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE); \