summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2016-01-17 19:05:52 (EST)
committer P. J. McDermott <pj@pehjota.net>2016-01-17 19:05:52 (EST)
commit8a9b1d3c71c8d25413c05e1e8d8f97a136c71159 (patch)
tree4bcefc56d1492301897e124fd18d4e706f5c0371 /Makefile.am
parentc56fa3989464679bbfef15d1e28ee4c883f860f1 (diff)
Makefile.am: Sign release archives
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b184ced..2efc0c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -161,6 +161,10 @@ release:
git push --tags origin master:master
md5sum $(DIST_ARCHIVES) >MD5SUMS
sha256sum $(DIST_ARCHIVES) >SHA256SUMS
+ set -e; \
+ for f in $(DIST_ARCHIVES); do \
+ gpg --armor --sign $${f}; \
+ done
ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE)
rsync -az --progress --stats $(DIST_ARCHIVES) MD5SUMS SHA256SUMS \
files@files.proteanos.com:files/pub/$(PACKAGE)/$(VERSION)/