summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-04-16 16:26:13 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-04-16 16:26:13 (EDT)
commitc89ed39fc853fbdbb2c506f10389e22ec5218d7d (patch)
treecdc844fec411b076a68a1d455a079f3b71ab5ea7 /Makefile.am
parent3112bee3d4ac6e770fe521a6db68c092d422c58e (diff)
Makefile.am: Define OPKG_CERT, USIGN_EMBEDDED, and USIGN
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e666da..2840306 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,7 +45,17 @@ prokit_SOURCES =
prokit_SHPPFLAGS = \
-DPKGDATADIR="$(pkgdatadir)" \
-DLOCALEDIR="$(localedir)" \
- -DTEXTDOMAIN="$(TEXTDOMAIN)"
+ -DTEXTDOMAIN="$(TEXTDOMAIN)" \
+ -DOPKG_CERT="$(pkglibexecdir)/opkg-cert"
+if EMBEDDED_USIGN
+pro_archman_SHPPFLAGS += \
+ -DUSIGN_EMBEDDED=true \
+ -DUSIGN="$(pkglibexecdir)/usign$(EXEEXT)"
+else
+pro_archman_SHPPFLAGS += \
+ -DUSIGN_EMBEDDED=false \
+ -DUSIGN="$(USIGN)"
+endif
prokit_LDADD = $(prokit_SOURCES:.sh=.sho)
EXTRA_prokit_DEPENDENCIES = config.sh