summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-04-21 23:34:39 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-04-21 23:34:39 (EDT)
commitfef7ed43edfbde6c6536bea88d6b56c1f27fe0e0 (patch)
treee1728da87d1df85b4a868fc9c514f30800d725f8 /Makefile.am
parente46a0d9eec06320e5e8fac9bb8e0a717b2ffa86d (diff)
Makefile.am: Override PACKAGE_STRING with git-describe output
This makes the test suite output and log a little more informative. Copied from pro-archman.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3514baa..ece0410 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
# Process this file with automake to produce an input makefile.
#
-# Copyright (C) 2013-2016 Patrick "P. J." McDermott
+# Copyright (C) 2013-2017 Patrick "P. J." McDermott
#
# This file is part of the ProteanOS Development Kit.
#
@@ -26,6 +26,16 @@ else
PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
endif
+# PACKAGE_STRING is used in the test suite output and log.
+# PACKAGE_VERSION can't be overridden. Automake ignores it in the IN_GIT
+# conditional (and throws a warning), and setting it to $(PACKAGE_VERSION_GIT)
+# outside the conditional causes PACKAGE_VERSION_GIT to reference itself.
+# VERSION is not set here because it is used by:
+# * Automake's distdir macro
+# * Automake's distdir target (which checks for $(VERSION) in NEWS)
+# * Our release target
+PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION_GIT)
+
MANUAL = ProteanOS Development Kit Manual
TEXTDOMAIN = $$(printf '%s\n' '$(PACKAGE)' | sed -e 's|-|_|g')