summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2015-12-07 17:20:04 (EST)
committer P. J. McDermott <pj@pehjota.net>2015-12-07 17:20:04 (EST)
commitb9aa6a15ea946c1d2ea622c8230576dceeb6ecee (patch)
tree06300ea2325c051756a4f904006f9e6751b671cb /configure.ac
parent75e4bde1e4d2a38dffed4b2ecfc950ca6b92dad4 (diff)
configure.ac: Find gunzip utility
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 299fda9..f97791f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,31 @@ AC_ARG_WITH(
]
)
AC_ARG_WITH(
+ [gunzip],
+ [AS_HELP_STRING([--with-gunzip=PATH], [path to gunzip utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-gunzip requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([gunzip is required])
+ ;;
+ *)
+ GUNZIP="${withval}"
+ AC_SUBST([GUNZIP])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([GUNZIP], [gunzip])
+ if test -z "${GUNZIP}"; then
+ AC_MSG_ERROR([gunzip not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
[sha256sum],
[AS_HELP_STRING([--with-sha256sum=PATH], [path to sha512sum utility])],
[