summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2015-12-07 13:41:11 (EST)
committer P. J. McDermott <pj@pehjota.net>2015-12-07 13:41:11 (EST)
commitc8479e88af53c50a5d23d83f57fb500251e75ab8 (patch)
tree1a46e96bdb01a5d7ab0b0c5b38c159cb4f1fa544 /configure.ac
parentb0b1cc9188d1d5621a2a9c9271b6271fd6c62229 (diff)
configure.ac: Find wget utility
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ea86f6..22997d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,32 @@ AC_ARG_WITH(
]
)
+AC_ARG_WITH(
+ [wget],
+ [AS_HELP_STRING([--with-wget=PATH], [path to wget utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-wget requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([wget is required])
+ ;;
+ *)
+ WGET="${withval}"
+ AC_SUBST([WGET])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([WGET], [wget])
+ if test -z "${WGET}"; then
+ AC_MSG_ERROR([wget not found])
+ fi
+ ]
+)
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([config.sh])
AC_OUTPUT()