summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 83026a8..f8cdfa8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,7 +81,7 @@ todo:
printf '\n'; \
printf 'Code comments:\n'; \
printf '==============\n\n'; \
- for f in $(SOURCES); do \
+ for f in $$(printf '%s\n' $(SOURCES) | sort -u); do \
printed=false; \
sed '=' "$(top_srcdir)/$${f}" | sed 'N; s/\n/ ./' | sed -n \
'$(todo_script)' | while read -r lineno line; do \