summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f15069..cf26f83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,10 @@ CLEANFILES = \
.builddirstamp
pkgdatacmddir = $(pkgdatadir)/cmd
pkgdataprofiledir = $(pkgdatadir)/profiles
+uninstall_dirs = \
+ '$(DESTDIR)$(pkgdataprofiledir)' \
+ '$(DESTDIR)$(pkgdatacmddir)' \
+ '$(DESTDIR)$(pkgdatadir)'
EXTRA_DIST = \
autogen.sh \
$(bin_sources) \
@@ -89,7 +93,7 @@ uninstall-local:
done
uninstall-hook:
- for dir in '$(DESTDIR)$(pkgdatacmddir)' '$(DESTDIR)$(pkgdatadir)'; do \
+ for dir in $(uninstall_dirs); do \
if [ -d "$${dir}" ]; then \
rmdir "$${dir}"; \
fi; \