summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b184ced..2efc0c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -161,6 +161,10 @@ release:
git push --tags origin master:master
md5sum $(DIST_ARCHIVES) >MD5SUMS
sha256sum $(DIST_ARCHIVES) >SHA256SUMS
+ set -e; \
+ for f in $(DIST_ARCHIVES); do \
+ gpg --armor --sign $${f}; \
+ done
ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE)
rsync -az --progress --stats $(DIST_ARCHIVES) MD5SUMS SHA256SUMS \
files@files.proteanos.com:files/pub/$(PACKAGE)/$(VERSION)/