summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d25018..ece0410 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
# Process this file with automake to produce an input makefile.
#
-# Copyright (C) 2013-2016 Patrick "P. J." McDermott
+# Copyright (C) 2013-2017 Patrick "P. J." McDermott
#
# This file is part of the ProteanOS Development Kit.
#
@@ -26,6 +26,16 @@ else
PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
endif
+# PACKAGE_STRING is used in the test suite output and log.
+# PACKAGE_VERSION can't be overridden. Automake ignores it in the IN_GIT
+# conditional (and throws a warning), and setting it to $(PACKAGE_VERSION_GIT)
+# outside the conditional causes PACKAGE_VERSION_GIT to reference itself.
+# VERSION is not set here because it is used by:
+# * Automake's distdir macro
+# * Automake's distdir target (which checks for $(VERSION) in NEWS)
+# * Our release target
+PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION_GIT)
+
MANUAL = ProteanOS Development Kit Manual
TEXTDOMAIN = $$(printf '%s\n' '$(PACKAGE)' | sed -e 's|-|_|g')
@@ -84,9 +94,12 @@ EXTRA_DIST = \
$(man8_sources) \
scripts/announce-release.sh \
tools/shpp.sh \
- tools/shld.sh
+ tools/shld.sh \
+ build-aux/tap-driver.sh \
+ tests/aux/tap-functions.sh
AM_TESTS_ENVIRONMENT = srcdir=$(top_srcdir) COLOR_TEST_LOGS=$(COLOR_TEST_LOGS)
+LOG_DRIVER = $(SHELL) $(top_srcdir)/build-aux/tap-driver.sh
.builddirstamp:
$(AM_V_GEN)touch .builddirstamp