summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 69c2186..9c5ddb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,6 +107,31 @@ AC_ARG_WITH(
]
)
AC_ARG_WITH(
+ [md5sum],
+ [AS_HELP_STRING([--with-md5sum=PATH], [path to md5sum utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-md5sum requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([md5sum is required])
+ ;;
+ *)
+ MD5SUM="${withval}"
+ AC_SUBST([MD5SUM])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([MD5SUM], [md5sum])
+ if test -z "${MD5SUM}"; then
+ AC_MSG_ERROR([md5sum not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
[sha256sum],
[AS_HELP_STRING([--with-sha256sum=PATH], [path to sha256sum utility])],
[