summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 299fda9..f97791f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,31 @@ AC_ARG_WITH(
]
)
AC_ARG_WITH(
+ [gunzip],
+ [AS_HELP_STRING([--with-gunzip=PATH], [path to gunzip utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-gunzip requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([gunzip is required])
+ ;;
+ *)
+ GUNZIP="${withval}"
+ AC_SUBST([GUNZIP])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([GUNZIP], [gunzip])
+ if test -z "${GUNZIP}"; then
+ AC_MSG_ERROR([gunzip not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
[sha256sum],
[AS_HELP_STRING([--with-sha256sum=PATH], [path to sha512sum utility])],
[