summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2016-01-23 15:25:47 (EST)
committer P. J. McDermott <pj@pehjota.net>2016-01-23 15:25:47 (EST)
commit3fb3f705281abe0b5b822ce1693dd7a5556f7c98 (patch)
tree1c5f42661dc6b29b75d805186886594824ad5a6d /configure.ac
parenta0db3a63e8f5f5796db3f4a631e6caca6432b791 (diff)
configure.ac: New "IN_GIT" conditional
Partially revert commit d6dcaad31f4ca0b44ae639adf788d5bf50f48cec.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a30d981..e212c05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,13 +23,13 @@ AC_INIT([ProteanOS Development Kit], [2.0.0],
[http://www.proteanos.com/dev/prokit/])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_SRCDIR([src/main.sh])
-if test -d "${srcdir}/.git"; then
- PACKAGE_VERSION="$(git describe --tags HEAD | sed 's|^.*/||')"
-fi
AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
AM_SILENT_RULES([yes])
+AM_CONDITIONAL([IN_GIT],
+ [test -d "${srcdir}/.git" && command -v git >/dev/null 2>&1])
+
AC_ARG_WITH(
[sh],
[AS_HELP_STRING([--with-sh], [POSIX-conformant shell with `local'])],