summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a30d981..e212c05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,13 +23,13 @@ AC_INIT([ProteanOS Development Kit], [2.0.0],
[http://www.proteanos.com/dev/prokit/])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_SRCDIR([src/main.sh])
-if test -d "${srcdir}/.git"; then
- PACKAGE_VERSION="$(git describe --tags HEAD | sed 's|^.*/||')"
-fi
AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
AM_SILENT_RULES([yes])
+AM_CONDITIONAL([IN_GIT],
+ [test -d "${srcdir}/.git" && command -v git >/dev/null 2>&1])
+
AC_ARG_WITH(
[sh],
[AS_HELP_STRING([--with-sh], [POSIX-conformant shell with `local'])],